exim_convert4r4 - Convert Exim configuration from v3 to v4 format




This script is provided to assist in updating Exim configuration files. It reads an Exim 3 configuration file on the standard input, and writes a modified file on the standard output. It also writes comments about what it has done to the standard error file. It assumes that the input is a valid Exim 3 configuration file. A typical call to the conversion script might be exim_convert4r4 < /etc/exim/exim.conf > /etc/exim4/exim4.conf.new The output file

MUST be checked and tested before trying to use it on a live system. The conversion script is just an aid which does a lot of the « grunt work ». It does not guarantee to produce an Exim 4 configuration that behaves exactly the same as the Exim 3 configuration it reads. Each option change in the new file is preceded by an identifying comment. In fact, the conversion script tends to make quite a mess of your configuration, and you should expect to go through it afterwards and tidy it up by hand. Unless you are running a very straightforward configuration, the automatic conversion is likely to generate a non-optimal configuration. You should not only check it thoroughly, but also run as many tests as you can, to ensure that it is working as you expect. In particular, you should test address routing, using -bt and -bv, and the policy controls, using -bh. If possible, you should also do some live tests (i.e. send and receive some messages) before putting Exim 4 into service. If you have a very complicated configuration, it is possible that exim_convert4r4 will break it in some situations, which is why thorough testing is strongly recommended.


This manual page needs a major re-work. If somebody knows better groff than us and has more experience in writing manual pages, any patches would be greatly appreciated.


R exim (8), the files in /usr/share/doc/exim4-base/, especially Exim4.upgrade.gz


This manual page was stitched together from Exim4.upgrade by Andreas Metzler <ametzler at downhill.at.eu.org>, for the Debian GNU/Linux system (but may be used by others).